blob: 88b3251bc51371506a26676f7adc4f3c2ee58736 [file] [log] [blame]
Thomas Jarosch77d409d2011-03-07 20:51:01 +00001# Set svn_revision to SVN revision number if you want to do a SVN build.
2# Parent source directory has to be "rockbox-rXXXXX"
3%define svn_revision 0
4
5%if 0%{?svn_revision}
6# SVN rockbox build
7Version: r%{svn_revision}
8%else
9# Normal rockbox release
Thomas Jarosch77d409d2011-03-07 20:51:01 +000010Version: 3.8
11%endif
12
13Name: rockbox
14Summary: High quality audio player
15License: GPL
16Group: Applications/Multimedia
17Vendor: rockbox.org
18Release: 1%{?dist}
19Url: http://www.rockbox.org
20Buildroot: %{_tmppath}/%{name}-%{version}-root
21Requires: SDL
22BuildRequires: SDL-devel
23# Note: rpm doesn't support 7z. You need to repack as .tar.bz2
Thomas Jarosch4594b132011-03-08 09:52:01 +000024# Source: http://download.rockbox.org/release/%{version}/%{name}-%{version}.7z
Thomas Jarosch77d409d2011-03-07 20:51:01 +000025Source: %{name}-%{version}.tar.bz2
26Prefix: /opt/rockbox
27
28%description
29Rockbox open source high quality audio player
30
31Features:
32- Supports over 20 sound codecs:
33 MP3, OGG, WAV, FLAC and many more
34- Navigate music by folders or tag database
35- Gapless playback and crossfading
36- Ability to create your own themes
37- Album art support
38
39Need more reasons?
40Find them here: http://www.rockbox.org/wiki/WhyRockbox
41
42%prep
43%setup -q
44
45%build
46mkdir build
47cd build
48
49../tools/configure --prefix=%{prefix} --target=sdlapp --lcdwidth=800 --lcdheight=480 --type=N
50
51make %{?_smp_mflags}
52
53%install
54cd build
55make PREFIX=$RPM_BUILD_ROOT/%{prefix} fullinstall
56
57%clean
58rm -fr $RPM_BUILD_ROOT
59
60%files
61%defattr(-,root,root)
62%{prefix}/bin/rockbox
63%{prefix}/lib/*
64%{prefix}/share/*